All plugins, extensions and future add-ons require at least PHP 5.3. We actually enforce this by checking during activation and the plugin will let you know if your PHP version is too old for us to support. We’ve chosen this PHP version because it gives us the opportunity to organise our code better, via namespaces. Using namespaces from the beginning makes it also a lot easier for us to exclude other PHP versions, should statistics indicate that there are very few users on that version.

We do our best to maintain compatibility with PHP 5.3 and up, but sometimes we deploy something that isn’t compatible. In Listings Jobs 0.2.2 you will find such a fix, which resolves a fatal error upon activation in PHP 5.3.

Thanks to Peder for reporting this via the support forums. 🙂